User Tools

Site Tools


difx:dependenciesdebian

Debian Package Dependencies

Common

 
apt-get install pkg-config g++ gfortran bison flex libexpat1-dev fftw3-dev autoconf automake libtool build-essential pgplot5 subversion libgsl-dev

Note pgplot5 comes from the non-free repository

Etch

apt-get install openmpi-dev

Lenny and later

apt-get install libopenmpi-dev openmpi-bin

Hops

If using Hops you may also need

apt-get install libx11-dev libpng12-0 libpng12-dev

If you will be using Espresso then you will also need mxdatetime:

apt-get install python-egenix-mxdatetime
difx/dependenciesdebian.txt · Last modified: 2019/05/13 15:12 by chrisphillips